UPDATE - 10:45 AM EST 3/17/2016 There were some performance issues reported after 5 PM yesterday for a short period of time. We are continuing to monitor our systems and implement changes that should alleviate issues for our end users. As soon as we have a resolution from our carrier we will post it here.
UPDATE - 2:00 PM EST 3/17/2016 At this time all systems are appear to be fully operational. We have not received an update from our carrier at this time. We are continuing to monitor all services and will alert as necessary.
UPDATE - 3:36 PM EST All Services seem to be restored. We are still watching this issue as we have not received a recent update or resolution from our carrier as of this time. We will continue to monitor and alert as necessary.
UPDATE - 12:20 PM EST The carrier may still be having issues but most services seem to be restored. We will be continuing to watch our systems for any issues that may arise.
Here is another direct note from our carrier.
"Our network engineers are currently working diligently with our upstream carriers as well as a network security firm to combat the attack and will continue to do so until all of the issues are resolved. Our senior leadership has also been in contact with the FBI. The FBI is considering these events a national security issue due to the number of firms impacted, the magnitude of the attacks and the persistence of these attacks."
UPDATE - 11:42 AM EST One of our carriers has again been under DDoS attack. Inbound and outbound calling have been affected.
Here is a direct note from our carrier.
"Many of you voiced concern over lack of updates on this ticket. We are concerned with the possibility that the perpetrator(s) of this attack may have access to public ticket updates and have therefore chosen to limit the information we put herein. Please know that we have made significant changes to prevent this and are continuing to address even this latest attack. We are not able to share additional information at this time due to the aforementioned concerns. We will provide details and include an RFO at a later date."
As of 09:15 EDT we are investigating performance issues with one of our service providers. This issue may result in occasional call quality issues or failure for calls to terminate properly. We are in contact with the provider and will update this incident with additional information as it is received.