1st October 2021

Calls not completing

Update: Carrier has indicated service is restored.

Update 3:25pm: The carrier is telling us that the issue has been identified and a fix is being implemented. You may see some over your services restored.

Update 2:50pm: We confirmed that carrier is still working to resolve the partial outage. They didn't provide any further details at this time.

One of our carriers is experiencing and issue that is causing customer's inbound and outbound calls to experience call quality issues. They are working to find a resolution. We will update when we know more from them.