Update: All services are operational at this time. As soon as we receive an Official RFO we will share it with those whom request.
Update: We have received confirmation that there is partial restoration of the services and hopefully within the next few minutes the entire service will be fully operational. As soon as we receive an Offical RFO we will share it with those whom request.
Our upstream carrier's engineers confirmed that there is an issue with inbound Michigan numbers. As soon as we have any further information we will update this status page.